Back to overview
Downtime

webpage, main server, and 2 other services are down

May 12 at 12:19pm CST

Resolved
May 12 at 05:36pm CST

webpage recovered.

Updated
May 12 at 05:36pm CST

main server, file sharing server, and control panel recovered.

Created
May 12 at 12:19pm CST

webpage, main server, file sharing server, and 1 other resource went down.