Back to overview
Downtime

webpage, main server, and 2 other services are down

Jun 12 at 12:24pm CST

Resolved
Jun 12 at 06:17pm CST

webpage recovered.

Updated
Jun 12 at 06:17pm CST

main server, file sharing server, and control panel recovered.

Created
Jun 12 at 12:24pm CST

webpage, main server, file sharing server, and 1 other resource went down.